Partial Outage – Product (Investigating)

Incident Report for Pear Deck Learning

Resolved

We have resolved the issue causing Presentation launches from Google Slides Add On to fail. Service has been fully restored.

We apologize for any trouble caused by this issue.
Posted May 29, 2026 - 10:10 PDT

Monitoring

We have implemented a fix to resolve issues related to launching Presentations within Google Slides Add On and service has been restored for our customers. We will continue to monitor performance to ensure full functionality.

We apologize for any trouble caused by this issue.
Posted May 29, 2026 - 08:34 PDT

Identified

We have identified the cause and are implemented a fix.
Posted May 29, 2026 - 07:54 PDT

Investigating

Some users may experience trouble launching Presentations within Google Slides Add On. We are currently investigating the issue and working towards a fix. Presentations can still be launched from the Pear Deck application directly using the "Present Existing" button. We will keep you updated here with additional details.

We sincerely apologize for any inconvenience.
Posted May 29, 2026 - 07:39 PDT
This incident affected: Pear Deck.